diff --git a/PKG-INFO b/PKG-INFO
index d4e9eaecd34f136d9c33b7723cb378898fde9548..2282411c55d84afaa0ac425840165bc81dae41b9 100644
--- a/PKG-INFO
+++ b/PKG-INFO
@@ -1,6 +1,6 @@
 Metadata-Version: 2.1
 Name: swh.deposit
-Version: 1.4.1
+Version: 1.4.2
 Summary: Software Heritage Deposit Server
 Home-page: https://forge.softwareheritage.org/source/swh-deposit/
 Author: Software Heritage developers
diff --git a/debian/changelog b/debian/changelog
index 926fbe5c55854c5c8ab81f1d2dfcb1df0eb1bbd8..54b02d5d957b0a9fdae11391ab3bd40f46e2cf61 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,8 +1,12 @@
-swh-deposit (1.4.1-1~swh1~bpo10+1) buster-swh; urgency=medium
+swh-deposit (1.4.2-1~swh1) unstable-swh; urgency=medium
 
-  * Rebuild for buster-swh
+  * New upstream release 1.4.2     - (tagged by Antoine R. Dumont
+    (@ardumont) <ardumont@softwareheritage.org> on 2023-11-23 12:14:27
+    +0100)
+  * Upstream changes:     - v1.4.2     - settings.production: Allow
+    extra azure configuration
 
- -- Software Heritage autobuilder (on jenkins-debian1) <jenkins@jenkins-debian1.internal.softwareheritage.org>  Mon, 20 Nov 2023 14:00:55 +0000
+ -- Software Heritage autobuilder (on jenkins-debian1) <jenkins@jenkins-debian1.internal.softwareheritage.org>  Thu, 23 Nov 2023 11:20:34 +0000
 
 swh-deposit (1.4.1-1~swh1) unstable-swh; urgency=medium
 
diff --git a/swh.deposit.egg-info/PKG-INFO b/swh.deposit.egg-info/PKG-INFO
index d4e9eaecd34f136d9c33b7723cb378898fde9548..2282411c55d84afaa0ac425840165bc81dae41b9 100644
--- a/swh.deposit.egg-info/PKG-INFO
+++ b/swh.deposit.egg-info/PKG-INFO
@@ -1,6 +1,6 @@
 Metadata-Version: 2.1
 Name: swh.deposit
-Version: 1.4.1
+Version: 1.4.2
 Summary: Software Heritage Deposit Server
 Home-page: https://forge.softwareheritage.org/source/swh-deposit/
 Author: Software Heritage developers
diff --git a/swh/deposit/settings/production.py b/swh/deposit/settings/production.py
index 81e6b7055b3d541acc18471e8d649a233a50dffa..61b5ee6065b9f082f95076b136cb1f35a54c1387 100644
--- a/swh/deposit/settings/production.py
+++ b/swh/deposit/settings/production.py
@@ -123,15 +123,27 @@ if cfg_azure:
                 f"Production: invalid configuration; missing {key} config entry."
             )
 
+    # Default options
+    options = dict(
+        azure_container=cfg_azure["container_name"],
+        connection_string=cfg_azure["connection_string"],
+    )
+
+    # Which may be enhanced with some extra options, lookup "object_parameters" in
+    # https://django-storages.readthedocs.io/en/latest/backends/azure.html
+    object_parameters = {}
+    for optional_config_key in ["content_type", "content_disposition"]:
+        if optional_config_key in cfg_azure:
+            object_parameters[optional_config_key] = cfg_azure[optional_config_key]
+
+    options.update(dict(object_parameters=object_parameters))
+
     STORAGES = {
         "staticfiles": {
             "BACKEND": "django.contrib.staticfiles.storage.StaticFilesStorage"
         },
         "default": {
             "BACKEND": "storages.backends.azure_storage.AzureStorage",
-            "OPTIONS": {
-                "azure_container": cfg_azure["container_name"],
-                "connection_string": cfg_azure["connection_string"],
-            },
+            "OPTIONS": options,
         },
     }